ICD Down for Maintenance
Incident Report for IntelCenter
Resolved
This incident has been resolved.
Posted May 07, 2020 - 22:15 EDT
Update
ICD is back up
Posted May 07, 2020 - 22:15 EDT
Investigating
The ICD is currently down for maintenance in preparation for a major upgrade. Thank you for your patience while we get everything in place for the upgrade. An update will be posted here as soon as the ICD is back online.
Posted May 07, 2020 - 21:49 EDT
This incident affected: IntelCenter Database (ICD) (ICD).