ICD Down
Incident Report for IntelCenter
Resolved
The issues has been resolved. Thanks for your patience while we got this sorted out!
Posted Nov 02, 2020 - 21:31 EST
Update
We are continuing to work on a fix for this issue.
Posted Nov 02, 2020 - 21:30 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 02, 2020 - 21:22 EST
Investigating
We are currently investigating this issue.
Posted Nov 02, 2020 - 20:03 EST
This incident affected: IntelCenter Database (ICD) (ICD).