ICD Outage
Incident Report for IntelCenter
Resolved
The issue has been resolved and the ICD is back up and running. Thanks again for your patience on this one!
Posted Sep 12, 2019 - 08:57 EDT
Investigating
The ICD is currently down. We are investigating the issue and will update here with more information as soon as we know more. Thanks for your patience while we get this sorted out.
Posted Sep 12, 2019 - 08:26 EDT
This incident affected: IntelCenter Database (ICD) (ICD).