ICD Outage
Incident Report for IntelCenter
Resolved
The issue has been resolved. Thanks again for your patience. All aspects of the ICD are functioning normally again.
Posted 11 months ago. Nov 06, 2017 - 20:39 EST
Identified
We have identified an issue that is preventing access to the ICD and are working on a fix. Thank you for your patience while we get this sorted. As soon an update is available it will be posted here.
Posted 11 months ago. Nov 06, 2017 - 20:02 EST