ICD Down
Incident Report for IntelCenter
Resolved
We have resolved the issue and the ICD is back up. Thanks for your patience!
Posted May 28, 2020 - 08:31 EDT
Update
We are continuing to investigate this issue.
Posted May 28, 2020 - 08:30 EDT
Investigating
The ICD is down. We are currently investigating the issue.
Posted May 28, 2020 - 07:18 EDT
This incident affected: IntelCenter Database (ICD) (ICD).