ICD Outage
Incident Report for IntelCenter
Resolved
Access to the ICD has been restored. Thanks for hanging in there while we worked the problem.
Posted almost 2 years ago. Dec 14, 2016 - 19:30 EST
Identified
We have identified an issue impacting access to the ICD and are working on a fix. As soon as we know more an update will be sent out. Thank you for your patience.
Posted almost 2 years ago. Dec 14, 2016 - 18:49 EST