Unscheduled Maintenance
Incident Report for IntelCenter
Resolved
The ICD is back online. Thank you for your patience!
Posted over 2 years ago. Aug 21, 2015 - 15:40 EDT
Identified
The ICD will be down for the next 5-15 minutes due to unscheduled maintenance. We apologize for the inconvenience and will send a message out as soon as the ICD is back online.
Posted over 2 years ago. Aug 21, 2015 - 15:20 EDT