ICD Outage
Incident Report for IntelCenter
Resolved
The issue has been resolved and all ICD systems are accessible and functioning normally again. Thank you for your patience while we worked through this one with our provider.
Posted 6 months ago. Aug 24, 2017 - 11:43 EDT
Identified
We are currently experiencing an issue impacting the connections to our data center. The issue is being addressed by our provider and we will provide updates here as we get them. Our apologies for the inconvenience.
Posted 6 months ago. Aug 24, 2017 - 02:18 EDT