ICD Access Issue
Incident Report for IntelCenter
Resolved
The issue impacting access to the ICD has been resolved. Thank you for your patience while we got the fix in place.
Posted almost 2 years ago. Apr 17, 2016 - 01:29 EDT
Investigating
We are currently investigating an issue impacting the ability of users to log into the IntelCenter Database (ICD). An update will be provided shortly as soon as we have identified the cause.
Posted almost 2 years ago. Apr 16, 2016 - 23:58 EDT