ICD Down for Emergency Maintenance
Incident Report for IntelCenter
Resolved
The ICD is back up and running. Thanks again for your patience!
Posted 8 months ago. Dec 05, 2018 - 09:11 EST
Investigating
The ICD is down for emergency maintenance. We are working hard to get it back up as soon as possible and will post an update here as soon as it is done. Thanks for your patience while we get this resolved!
Posted 8 months ago. Dec 05, 2018 - 07:35 EST
This incident affected: IntelCenter Database (ICD) (ICD).