ICD Outage
Incident Report for IntelCenter
Resolved
The ICD is back up. Thanks again for your patience while we worked to get this one fixed.
Posted 3 months ago. Mar 20, 2018 - 12:34 EDT
Identified
The ICD is currently down. We have identified the issue and are working to get it resolved as quickly as possible. As soon as we have an update it will be posted here. Thanks for your patience will we sort this one out.
Posted 3 months ago. Mar 20, 2018 - 07:34 EDT